Tried to add funds, money gone and no funds added


I recently tried to add an extra 10 dollars to my account to bring my wallet up to 20 dollars. Problem is when I added funds like I usually do it gave me an error after hitting “confirm add funds” and showed “FRAUD_DETECTION” or something like that. Now I checked my account and the funds have not been added yet the money is gone from my bank. What’s up with that? I’ve been purchasing stuff on here for almost 1 year now and I’ve never had this issue before.

Some said if that happen its already charged your card/bank by the gameflip payment processor and the game flip fraud prevention reviewing your billing/payment information, please stay tune to your email as they might be need additional information to you, or contact gameflip support. they might help for sure

Usually this happen if some information on your card has been changed or the pattern algorithm Ex : you always add funds $5 and $10, and suddenly came for $20

I suggest to wait overall 24hours, maybe there’s delay, bug etc,

I’ve reached out do gameflip support, but I’ll have to see if they respond. I guess patience is key…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.