Gameflip App issues

I have an odd situation with the app. First it doesn’t work on my current phone a Galaxy note 2. It says it is incompatible. So I installed it on my old phone because it apparently is compatible there. It worked fine for a few weeks until I got this error message:

“No Network Connection”
“Gameflip cannot connect to the server. Please ensure you have internet connection and try again!”

Problem is my phone is connected to the internet. It is connected to my wifi. I tried re-installing it, using another wifi. I even tried using hotspot from my note 2 phone and still no luck.

There’s no way I could get into any settings options either with the app as it stays stuck there on that “no network” screen.

1 Like


Which model is your “old phone”?. Also, can you tell me what is the Android version of it?

Please, send me screenshots of this error as well. I’ll try my best to help you then.


My old one is a LG optimus f60.

The android version is 4.4.2

Here’s the screenshot of it:

Do you have a phone with Android version 5 (Lollipop) 2014 or higher?

No I don’t have one that is lollipop or higher. It was working fine before even after an update. Then just one day it stopped working. Try as I might the phones won’t update. They say they are up to date.

I’m in this boat as well. I think it was wednesday when my app started issues. It would at least let me know when there was a notification. I reinstalled the app and I don’t even get that anymore.

Try changing the DNS server for your wifi to and Sometimes it’s just a network issue.

Hello guys,

I’m sorry to inform that Gameflip did a security upgrade and due to that Android 4.4 or lower won’t be supported.

I strongly suggest that you guys get an Android 5+ device so you can properly use the app.

Thank you!

@Gingerbread_Man @vucadby_vucadby

Please try the 1.27.1 version of the app and see if you can log in now.

1 Like

@galacticarm It works now! I can login, view listings, reply, do everything! Kick ■■■ man! Thanks! :smiley: